aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-12-28 18:57:02 +0100
committerAndreas Schneider <asn@cynapses.org>2010-12-28 22:14:47 +0100
commit361e37dc66b374b432f8db29f3169ab00fd0cd03 (patch)
treec740c457909b63aa03d1c7bb5e0089c79cd88aa5 /tests/client/CMakeLists.txt
parentdf55918a41cc8a994bfcb955bd6d8ca068f5f62f (diff)
downloadlibssh-361e37dc66b374b432f8db29f3169ab00fd0cd03.tar.gz
libssh-361e37dc66b374b432f8db29f3169ab00fd0cd03.tar.xz
libssh-361e37dc66b374b432f8db29f3169ab00fd0cd03.zip
tests: Added a torture_sftp_static test.
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rw-r--r--tests/client/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index f8c2d98..d3bfc8f 100644
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -4,3 +4,6 @@ add_cmockery_test(torture_algorithms torture_algorithms.c ${TORTURE_LIBRARY})
add_cmockery_test(torture_auth torture_auth.c ${TORTURE_LIBRARY})
add_cmockery_test(torture_knownhosts torture_knownhosts.c ${TORTURE_LIBRARY})
add_cmockery_test(torture_proxycommand torture_proxycommand.c ${TORTURE_LIBRARY})
+if (WITH_SFTP)
+ add_cmockery_test(torture_sftp_static torture_sftp_static.c ${TORTURE_LIBRARY})
+endif (WITH_SFTP)