aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-12-28 13:41:33 +0100
committerAndreas Schneider <asn@cynapses.org>2010-12-28 22:14:47 +0100
commit17f592d4dd25eae98b1a8378625adc454976fcb6 (patch)
tree753072ed82b75b78801dd0e5786a8bbe9b272e64 /tests/CMakeLists.txt
parent7dc183126ab53d0788d48066054a8282d63c0d17 (diff)
downloadlibssh-17f592d4dd25eae98b1a8378625adc454976fcb6.tar.gz
libssh-17f592d4dd25eae98b1a8378625adc454976fcb6.tar.xz
libssh-17f592d4dd25eae98b1a8378625adc454976fcb6.zip
tests: Start to migrate tests to cmockery.
https://code.google.com/p/cmockery/wiki/Cmockery_Unit_Testing_Framework
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 2 insertions, 7 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index da1fb41..42a377b 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,9 +1,5 @@
project(tests C)
-if (UNIX AND NOT LINUX)
- find_package(Argp)
-endif (UNIX AND NOT LINUX)
-
set(TORTURE_LIBRARY torture)
include_directories(
@@ -16,14 +12,13 @@ include_directories(
)
# create test library
-add_library(${TORTURE_LIBRARY} SHARED torture.c cmdline.c)
+add_library(${TORTURE_LIBRARY} SHARED torture.c)
target_link_libraries(${TORTURE_LIBRARY}
- ${CHECK_LIBRARIES}
+ ${CMOCKERY_LIBRARY}
${LIBSSH_STATIC_LIBRARY}
${LIBSSH_LINK_LIBRARIES}
${LIBSSH_THREADS_STATIC_LIBRARY}
${LIBSSH_THREADS_LINK_LIBRARIES}
- ${ARGP_LIBRARIES}
)
set(TEST_TARGET_LIBRARIES ${SUPPORT_LIBRARY} ${LIBSSH_LINK_LIBRARIES})