aboutsummaryrefslogtreecommitdiff
path: root/libssh/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2009-04-27 10:58:29 +0000
committerAndreas Schneider <mail@cynapses.org>2009-04-27 10:58:29 +0000
commitc1c4f299ff8881fe0c8d51790d49bfb5fcd632df (patch)
treeb6d448bb156f7d4025778e5f76740ab7edb30dac /libssh/CMakeLists.txt
parent99946c7bcc3be1a48e2546254e3c7e9ca8375412 (diff)
downloadlibssh-c1c4f299ff8881fe0c8d51790d49bfb5fcd632df.tar.gz
libssh-c1c4f299ff8881fe0c8d51790d49bfb5fcd632df.tar.xz
libssh-c1c4f299ff8881fe0c8d51790d49bfb5fcd632df.zip
Add option to build with or without sftp support.
git-svn-id: svn+ssh://svn.berlios.de/svnroot/repos/libssh/trunk@618 7dcaeef0-15fb-0310-b436-a5af3365683c
Diffstat (limited to 'libssh/CMakeLists.txt')
-rw-r--r--libssh/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/libssh/CMakeLists.txt b/libssh/CMakeLists.txt
index e3ee26b..260d743 100644
--- a/libssh/CMakeLists.txt
+++ b/libssh/CMakeLists.txt
@@ -85,13 +85,25 @@ set(libssh_SRCS
options.c
packet.c
session.c
- sftp.c
- sftpserver.c
socket.c
string.c
wrapper.c
)
+if (WITH_SFTP)
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ sftp.c
+ )
+
+ if (WITH_SERVER)
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ sftpserver.c
+ )
+ endif (WITH_SERVER)
+endif (WITH_SFTP)
+
if (WITH_SSH1)
set(libssh_SRCS
${libssh_SRCS}