aboutsummaryrefslogtreecommitdiff
path: root/libssh/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2009-03-28 21:58:54 +0000
committerAndreas Schneider <mail@cynapses.org>2009-03-28 21:58:54 +0000
commit78b6e25ededc7df14304b002fd8697232ca97e46 (patch)
tree5811957d8d5ab436b861719748d371540957fe41 /libssh/CMakeLists.txt
parente02a6e0225adb88b3eef91c479b9a50065fcdd5e (diff)
downloadlibssh-78b6e25ededc7df14304b002fd8697232ca97e46.tar.gz
libssh-78b6e25ededc7df14304b002fd8697232ca97e46.tar.xz
libssh-78b6e25ededc7df14304b002fd8697232ca97e46.zip
Fix compilation of the server with option turned off.
git-svn-id: svn+ssh://svn.berlios.de/svnroot/repos/libssh/trunk@294 7dcaeef0-15fb-0310-b436-a5af3365683c
Diffstat (limited to 'libssh/CMakeLists.txt')
-rw-r--r--libssh/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/libssh/CMakeLists.txt b/libssh/CMakeLists.txt
index 9c78d0d..a62ec06 100644
--- a/libssh/CMakeLists.txt
+++ b/libssh/CMakeLists.txt
@@ -89,7 +89,6 @@ set(libssh_SRCS
misc.c
options.c
packet.c
- server.c
session.c
sftp.c
sftpserver.c
@@ -98,6 +97,13 @@ set(libssh_SRCS
wrapper.c
)
+if (WITH_SERVER)
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ server.c
+ )
+endif (WITH_SERVER)
+
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
${LIBSSH_PRIVATE_INCLUDE_DIRS}