aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2010-07-16 23:14:47 +0200
committerAris Adamantiadis <aris@0xbadc0de.be>2010-07-16 23:14:47 +0200
commita8efffa96963e47ca604b251b09cc23999ac512c (patch)
tree5bcaf5003efc44202212acd4fbce3829bde5251c /examples/CMakeLists.txt
parentef0215fcf24cf552648530c1c20440f2719a606b (diff)
downloadlibssh-a8efffa96963e47ca604b251b09cc23999ac512c.tar.gz
libssh-a8efffa96963e47ca604b251b09cc23999ac512c.tar.xz
libssh-a8efffa96963e47ca604b251b09cc23999ac512c.zip
New example for port forwarding
Conflicts: examples/CMakeLists.txt
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index b912df5..867869c 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -16,6 +16,7 @@ add_executable(scp_download scp_download.c ${examples_SRCS})
add_executable(samplessh sample.c ${examples_SRCS})
add_executable(exec exec.c ${examples_SRCS})
add_executable(senddata senddata.c ${examples_SRCS})
+add_executable(sshnetcat sshnetcat.c ${examples_SRCS})
add_executable(libsshpp libsshpp.cpp)
@@ -25,6 +26,8 @@ target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
target_link_libraries(exec ${LIBSSH_SHARED_LIBRARY})
target_link_libraries(senddata ${LIBSSH_SHARED_LIBRARY})
target_link_libraries(libsshpp ${LIBSSH_SHARED_LIBRARY})
+target_link_libraries(sshnetcat ${LIBSSH_SHARED_LIBRARY})
+
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}