aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2009-10-09 21:44:05 +0200
committerAris Adamantiadis <aris@0xbadc0de.be>2009-10-09 21:44:05 +0200
commit58294442d3589f464571ff86071a260e0f548d26 (patch)
tree355f2683d657ec44de047741b9fc8202d0c46d83 /examples/CMakeLists.txt
parent2e9c13dad00c038fe7fa0eb8e81fc8990cb8893c (diff)
downloadlibssh-58294442d3589f464571ff86071a260e0f548d26.tar.gz
libssh-58294442d3589f464571ff86071a260e0f548d26.tar.xz
libssh-58294442d3589f464571ff86071a260e0f548d26.zip
Moved samples into examples directory
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 3dbf615..ddc95a7 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -8,6 +8,7 @@ set(examples_SRCS
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
+ ${LIBSSH_PRIVATE_INCLUDE_DIRS}
)
add_executable(libssh_scp libssh_scp.c ${examples_SRCS})
@@ -16,3 +17,18 @@ add_executable(scp_download scp_download.c ${examples_SRCS})
target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY})
target_link_libraries(scp_download ${LIBSSH_SHARED_LIBRARY})
+include_directories(
+ ${LIBSSH_PUBLIC_INCLUDE_DIRS}
+ ${LIBSSH_PRIVATE_INCLUDE_DIRS}
+)
+
+if (WITH_SFTP)
+ add_executable(samplessh sample.c)
+ target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
+endif (WITH_SFTP)
+
+if (WITH_SERVER)
+ add_executable(samplesshd samplesshd.c)
+ target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY})
+endif (WITH_SERVER)
+