aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2009-11-06 19:21:18 +0100
committerAris Adamantiadis <aris@0xbadc0de.be>2009-11-06 19:21:18 +0100
commit14ae9a7f0c7ce7a9fa2972ef29c1c8cb86242d4d (patch)
treed57cad526552af0c68a5d5b6c7ddf85e178099fb /examples/CMakeLists.txt
parent51f191810977da3432d290c712fbeed0a9a8e434 (diff)
downloadlibssh-14ae9a7f0c7ce7a9fa2972ef29c1c8cb86242d4d.tar.gz
libssh-14ae9a7f0c7ce7a9fa2972ef29c1c8cb86242d4d.tar.xz
libssh-14ae9a7f0c7ce7a9fa2972ef29c1c8cb86242d4d.zip
Moved sftp parts into a new example
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 45087ca..c62935c 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -13,9 +13,11 @@ include_directories(
add_executable(libssh_scp libssh_scp.c ${examples_SRCS})
add_executable(scp_download scp_download.c ${examples_SRCS})
+add_executable(samplessh sample.c)
target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY})
target_link_libraries(scp_download ${LIBSSH_SHARED_LIBRARY})
+target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
@@ -23,8 +25,8 @@ include_directories(
)
if (WITH_SFTP)
- add_executable(samplessh sample.c)
- target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
+ add_executable(samplesftp samplesftp.c ${examples_SRCS})
+ target_link_libraries(samplesftp ${LIBSSH_SHARED_LIBRARY})
endif (WITH_SFTP)
if (WITH_SERVER)