aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d087366d..ac6a3598 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,7 @@ include(MacroCopyFile)
# search for libraries
find_package(ZLIB REQUIRED)
+find_package(Check)
if (WITH_GCRYPT)
find_package(GCrypt REQUIRED)
@@ -75,8 +76,13 @@ install(
if (UNIX AND NOT WIN32)
add_subdirectory(examples)
-
endif (UNIX AND NOT WIN32)
+
+if (CHECK_FOUND AND WITH_TESTING)
+ include(AddCheckTest)
+ add_subdirectory(tests)
+endif (CHECK_FOUND AND WITH_TESTING)
+
MESSAGE(STATUS "********************************************")
MESSAGE(STATUS "********** ${PROJECT_NAME} build options : **********")
if (WITH_LIBZ)