aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2012-10-07 11:10:27 +0200
committerAndreas Schneider <asn@cryptomilk.org>2012-10-07 11:10:27 +0200
commitc81010e2f7e560081d78d15e54789af45c0a4999 (patch)
treebd38f40fe2a56388f1373454d72f8186aa003b25 /tests/CMakeLists.txt
parentc078e36219fc23aed8fff9b5efce33e09e177e20 (diff)
downloadlibssh-c81010e2f7e560081d78d15e54789af45c0a4999.tar.gz
libssh-c81010e2f7e560081d78d15e54789af45c0a4999.tar.xz
libssh-c81010e2f7e560081d78d15e54789af45c0a4999.zip
test: Use cmocka instead of cmockery.
cmocka is the successor of cmockery. http://git.cryptomilk.org/projects/cmocka.git/
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 6942bacb..bb39755a 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -8,7 +8,7 @@ set(TORTURE_LIBRARY torture)
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
- ${CMOCKERY_INCLUDE_DIR}
+ ${CMOCKA_INCLUDE_DIR}
${OPENSSL_INCLUDE_DIRS}
${GCRYPT_INCLUDE_DIRS}
${ZLIB_INCLUDE_DIRS}
@@ -20,7 +20,7 @@ include_directories(
# create test library
add_library(${TORTURE_LIBRARY} STATIC cmdline.c torture.c)
target_link_libraries(${TORTURE_LIBRARY}
- ${CMOCKERY_LIBRARY}
+ ${CMOCKA_LIBRARY}
${LIBSSH_STATIC_LIBRARY}
${LIBSSH_LINK_LIBRARIES}
${LIBSSH_THREADS_STATIC_LIBRARY}
@@ -30,7 +30,7 @@ target_link_libraries(${TORTURE_LIBRARY}
set(TEST_TARGET_LIBRARIES
${TORTURE_LIBRARY}
- ${CMOCKERY_LIBRARY}
+ ${CMOCKA_LIBRARY}
${LIBSSH_STATIC_LIBRARY}
${LIBSSH_LINK_LIBRARIES}
${LIBSSH_THREADS_STATIC_LIBRARY}