aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJon Simons <jon@jonsimons.org>2014-10-10 12:38:45 -0700
committerAndreas Schneider <asn@cryptomilk.org>2014-10-12 15:01:02 +0200
commit9dc932c02b6d88b380fdaee0b7184b23e2b85c2f (patch)
treea8b4e4152b218be2f00b4f425c534db16643651f /tests/CMakeLists.txt
parentaaae6cd97d3b99061fcf5444d491895690fb4cde (diff)
downloadlibssh-9dc932c02b6d88b380fdaee0b7184b23e2b85c2f.tar.gz
libssh-9dc932c02b6d88b380fdaee0b7184b23e2b85c2f.tar.xz
libssh-9dc932c02b6d88b380fdaee0b7184b23e2b85c2f.zip
tests: introduce pkd_hello
Introduce a sample public-key testing daemon to the 'pkd' test directory, and add support code for cycling through various combinations of different key exchange, cipher, and MAC algorithms. The goal of the 'pkd_hello' test is to make it easy to test interactions between non-libssh clients and a libssh-server, and to provide a starting point for testing new implementations for key types, ciphers, MACs, and so on. The thinking is that testing a new algorithm should be as simple as adding a new line for it in the PKDTESTS_* lists. Macros are used to generate the tests and helper functions for a couple of clients -- here, OpenSSH and dropbear are included for the first cut. If binaries are found for these clients, their test lists will be enabled; when binaries are not found for a given client, those tests are skipped. Tests are run in one large batch by default, but can also be run individually to help with tracking down things like signature bugs that may take many iterations to reproduce. Each test logs its stdout and stderr to its own file, which is cleaned up when a test succeeds. For failures, those logs can be combined with verbose libssh output from pkd itself to start debugging things. Some example usages: pkd_hello Run all tests with default number of iterations. pkd_hello --list List available individual test names. pkd_hello -i 1000 -t torture_pkd_openssh_ecdsa_256_ecdh_sha2_nistp256 Run only the torture_pkd_openssh_ecdsa_256_ecdh_sha2_nistp256 testcase 1000 times. pkd_hello -v -v -v -v -e -o Run all tests with maximum libssh and pkd logging. Included in the tests are passes for all existing kex, cipher, and MAC algorithms. BUG: https://red.libssh.org/issues/144 Signed-off-by: Jon Simons <jon@jonsimons.org> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index e1a8166b..cba1d303 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -38,6 +38,7 @@ set(TEST_TARGET_LIBRARIES
)
add_subdirectory(unittests)
+
if (WITH_CLIENT_TESTING)
add_subdirectory(client)
endif (WITH_CLIENT_TESTING)
@@ -46,3 +47,4 @@ if (WITH_BENCHMARKS)
add_subdirectory(benchmarks)
endif (WITH_BENCHMARKS)
+add_subdirectory(pkd)