aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-06-03 12:36:00 +0200
committerAndreas Schneider <asn@cynapses.org>2010-06-03 12:36:00 +0200
commit5dd4f7604f8007df1a11ff0cab55423a622342bc (patch)
tree0570bc1200183b4be958bedf5a4e5c86cb929678 /tests/CMakeLists.txt
parent94ce1ea45119770817676c25e15fe58a503a4db2 (diff)
downloadlibssh-5dd4f7604f8007df1a11ff0cab55423a622342bc.tar.gz
libssh-5dd4f7604f8007df1a11ff0cab55423a622342bc.tar.xz
libssh-5dd4f7604f8007df1a11ff0cab55423a622342bc.zip
tests: Move client tests to a seperate directory.
Tests which require a running sshd should go to tests/client.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 817d3a73..29986631 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -17,3 +17,6 @@ target_link_libraries(${TORTURE_LIBRARY} ${CHECK_LIBRARIES} ${LIBSSH_STATIC_LIBR
set(TEST_TARGET_LIBRARIES ${SUPPORT_LIBRARY} ${LIBSSH_LINK_LIBRARIES})
add_subdirectory(unittests)
+if (WITH_CLIENT_TESTING)
+ add_subdirectory(client)
+endif (WITH_CLIENT_TESTING)