aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-09-06 14:54:16 +0200
committerAndreas Schneider <asn@cynapses.org>2010-09-06 15:17:03 +0200
commitfbe102bada583f308450c27e256053b51643a532 (patch)
treea855a670d43df50647b5f90a89e15c093f26793f /src/CMakeLists.txt
parent2cca490076841b431d7a83d020d90e1ad00bbca5 (diff)
downloadlibssh-fbe102bada583f308450c27e256053b51643a532.tar.gz
libssh-fbe102bada583f308450c27e256053b51643a532.tar.xz
libssh-fbe102bada583f308450c27e256053b51643a532.zip
threads: Build a libssh threading library.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b158ae6c..8f20c7b8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -202,3 +202,6 @@ if (WITH_STATIC_LIB)
)
endif (WITH_STATIC_LIB)
+if (CMAKE_HAVE_THREADS_LIBRARY)
+ add_subdirectory(threads)
+endif (CMAKE_HAVE_THREADS_LIBRARY)