aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2011-09-17 22:47:56 +0200
committerAndreas Schneider <asn@cryptomilk.org>2011-09-18 21:37:18 +0200
commitdc42a1757fdbbf5b0ffd877649b6cf08b1385420 (patch)
tree7203b92aa25af19d4be5228f859ea0d416d4baa2 /src/CMakeLists.txt
parent7202a26b6ce9dc30a3764ce177337051d5136bcf (diff)
downloadlibssh-dc42a1757fdbbf5b0ffd877649b6cf08b1385420.tar.gz
libssh-dc42a1757fdbbf5b0ffd877649b6cf08b1385420.tar.xz
libssh-dc42a1757fdbbf5b0ffd877649b6cf08b1385420.zip
gzip: Fix zlib support.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d783e7ac..c230ef6a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -86,7 +86,6 @@ set(libssh_SRCS
ecdh.c
error.c
getpass.c
- gzip.c
init.c
kex.c
known_hosts.c
@@ -157,6 +156,13 @@ if (WITH_SERVER)
)
endif (WITH_SERVER)
+if (WITH_ZLIB)
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ gzip.c
+ )
+endif(WITH_ZLIB)
+
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
${LIBSSH_PRIVATE_INCLUDE_DIRS}