aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2011-08-28 14:29:17 +0200
committerAndreas Schneider <asn@cryptomilk.org>2011-08-28 14:29:17 +0200
commit7c28d0ce6d38a4e99e981fc3abf380e4cf29a57e (patch)
treea8469d98e0b03f2102cde90bc6bbdf21df7047d1 /src/CMakeLists.txt
parent5cf23522de543153fc0abcb4d33be1c1115a7aef (diff)
downloadlibssh-7c28d0ce6d38a4e99e981fc3abf380e4cf29a57e.tar.gz
libssh-7c28d0ce6d38a4e99e981fc3abf380e4cf29a57e.tar.xz
libssh-7c28d0ce6d38a4e99e981fc3abf380e4cf29a57e.zip
pki: Compile pki_gcrypt.c only if we need it.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 392944a1..79b69532 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -103,7 +103,6 @@ set(libssh_SRCS
packet.c
pcap.c
pki.c
- pki_gcrypt.c
poll.c
session.c
scp.c
@@ -118,6 +117,7 @@ if (WITH_GCRYPT)
${libssh_SRCS}
libgcrypt.c
gcrypt_missing.c
+ pki_gcrypt.c
)
else (WITH_GCRYPT)
set(libssh_SRCS