aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2013-07-22 10:50:35 +0200
committerAndreas Schneider <asn@cryptomilk.org>2013-07-23 10:44:51 +0200
commite1576ef55a186c58b20a3fba3ecf5fef97b88959 (patch)
treea26e3c8f0a4dc6be705d65eebdb9d7bf8eb68146 /examples/CMakeLists.txt
parentdf81a05505514b384d10c9b192137584040e4984 (diff)
downloadlibssh-e1576ef55a186c58b20a3fba3ecf5fef97b88959.tar.gz
libssh-e1576ef55a186c58b20a3fba3ecf5fef97b88959.tar.xz
libssh-e1576ef55a186c58b20a3fba3ecf5fef97b88959.zip
cmake: Don't build examples on Windows but on Unix.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt29
1 files changed, 14 insertions, 15 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 842f022d..a5210d68 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -15,7 +15,7 @@ if (BSD OR SOLARIS)
find_package(Argp)
endif (BSD OR SOLARIS)
-if (LINUX)
+if (UNIX AND NOT WIN32)
add_executable(libssh_scp libssh_scp.c ${examples_SRCS})
target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY})
@@ -37,27 +37,26 @@ if (LINUX)
target_link_libraries(samplesftp ${LIBSSH_SHARED_LIBRARY})
endif (WITH_SFTP)
-endif (LINUX)
-
add_executable(samplessh sample.c ${examples_SRCS})
target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
-if (WITH_SERVER)
- add_executable(samplesshd samplesshd.c)
- target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
+ if (WITH_SERVER)
+ add_executable(samplesshd samplesshd.c)
+ target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
- if (WITH_GSSAPI)
- add_executable(samplesshd-cb samplesshd-cb.c)
- target_link_libraries(samplesshd-cb ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
+ if (WITH_GSSAPI)
+ add_executable(samplesshd-cb samplesshd-cb.c)
+ target_link_libraries(samplesshd-cb ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
- add_executable(proxy proxy.c)
- target_link_libraries(proxy ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
- endif (WITH_GSSAPI)
+ add_executable(proxy proxy.c)
+ target_link_libraries(proxy ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
+ endif (WITH_GSSAPI)
- add_executable(samplesshd-kbdint samplesshd-kbdint.c)
- target_link_libraries(samplesshd-kbdint ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
+ add_executable(samplesshd-kbdint samplesshd-kbdint.c)
+ target_link_libraries(samplesshd-kbdint ${LIBSSH_SHARED_LIBRARY} ${ARGP_LIBRARIES})
-endif (WITH_SERVER)
+ endif (WITH_SERVER)
+endif (UNIX AND NOT WIN32)
add_executable(exec exec.c ${examples_SRCS})
target_link_libraries(exec ${LIBSSH_SHARED_LIBRARY})