aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2009-03-08 14:05:41 +0000
committerAndreas Schneider <mail@cynapses.org>2009-03-08 14:05:41 +0000
commitb4cebfb03d1b234e0287397d0ef96d335f5999ac (patch)
tree80839bf162b97664dd66a4dc49457d81646b1ae3 /CMakeLists.txt
parent461d9413d3c32066953f4ed97b8d4d8fc6f169b0 (diff)
downloadlibssh-b4cebfb03d1b234e0287397d0ef96d335f5999ac.tar.gz
libssh-b4cebfb03d1b234e0287397d0ef96d335f5999ac.tar.xz
libssh-b4cebfb03d1b234e0287397d0ef96d335f5999ac.zip
Fix compilation and installation of libssh.
git-svn-id: svn+ssh://svn.berlios.de/svnroot/repos/libssh/trunk@250 7dcaeef0-15fb-0310-b436-a5af3365683c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59422478..46fd3aa7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,8 +59,10 @@ add_subdirectory(libssh)
# build samples
include_directories(${CMAKE_SOURCE_DIR}/include)
-add_executable(samplessh sample.c)
-add_executable(samplesshd samplesshd.c)
+if (UNIX AND NOT WIN32)
+ add_executable(samplessh sample.c)
+ add_executable(samplesshd samplesshd.c)
-target_link_libraries(samplessh ${LIBSSH_LIBRARY})
-target_link_libraries(samplesshd ${LIBSSH_LIBRARY})
+ target_link_libraries(samplessh ${LIBSSH_LIBRARY})
+ target_link_libraries(samplesshd ${LIBSSH_LIBRARY})
+endif (UNIX AND NOT WIN32)