aboutsummaryrefslogtreecommitdiff
path: root/tests/fuzz/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/fuzz/CMakeLists.txt')
-rw-r--r--tests/fuzz/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/fuzz/CMakeLists.txt b/tests/fuzz/CMakeLists.txt
index d8663b51..bfbf9c4e 100644
--- a/tests/fuzz/CMakeLists.txt
+++ b/tests/fuzz/CMakeLists.txt
@@ -4,7 +4,7 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
add_executable(ssh_client_fuzzer ssh_client_fuzzer.cpp)
target_link_libraries(ssh_client_fuzzer
PRIVATE
- ${LIBSSH_STATIC_LIBRARY})
+ ssh::static)
set_target_properties(ssh_client_fuzzer
PROPERTIES
COMPILE_FLAGS "-fsanitize=fuzzer"
@@ -14,7 +14,7 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
add_executable(ssh_server_fuzzer ssh_server_fuzzer.cpp)
target_link_libraries(ssh_server_fuzzer
PRIVATE
- ${LIBSSH_STATIC_LIBRARY})
+ ssh::static)
set_target_properties(ssh_server_fuzzer
PROPERTIES
COMPILE_FLAGS "-fsanitize=fuzzer"