aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rwxr-xr-x[-rw-r--r--]tests/client/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index e6adfe36..c99c94ef 100644..100755
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -4,10 +4,12 @@ find_package(socket_wrapper)
set(LIBSSH_CLIENT_TESTS
torture_algorithms
+ torture_client_callbacks
torture_client_config
torture_connect
torture_hostkey
torture_auth
+ torture_auth_cert
torture_rekey
torture_forward
torture_knownhosts
@@ -15,6 +17,7 @@ set(LIBSSH_CLIENT_TESTS
torture_proxycommand
torture_session
torture_request_env
+ torture_request_pty_modes
torture_client_global_requests)
find_program(SCP_EXECUTABLE NAMES scp)
@@ -43,19 +46,28 @@ if (WITH_SFTP)
endif()
set(LIBSSH_CLIENT_TESTS
${LIBSSH_CLIENT_TESTS}
+ torture_sftp_init
torture_sftp_ext
torture_sftp_canonicalize_path
torture_sftp_dir
torture_sftp_read
torture_sftp_fsync
+ torture_sftp_hardlink
+ torture_sftp_limits
+ torture_sftp_rename
+ torture_sftp_expand_path
+ torture_sftp_aio
${SFTP_BENCHMARK_TESTS})
endif (WITH_SFTP)
+set(TORTURE_CLIENT_ENVIRONMENT ${TORTURE_ENVIRONMENT})
+list(APPEND TORTURE_CLIENT_ENVIRONMENT NSS_WRAPPER_HOSTS=${CMAKE_BINARY_DIR}/tests/etc/hosts)
+
foreach(_CLI_TEST ${LIBSSH_CLIENT_TESTS})
add_cmocka_test(${_CLI_TEST}
SOURCES ${_CLI_TEST}.c
COMPILE_OPTIONS ${DEFAULT_C_COMPILE_FLAGS}
- LINK_LIBRARIES ${TORTURE_LIBRARY}
+ LINK_LIBRARIES ${TORTURE_LIBRARY} util
)
if (OSX)
@@ -69,6 +81,6 @@ foreach(_CLI_TEST ${LIBSSH_CLIENT_TESTS})
TEST
${_CLI_TEST}
PROPERTY
- ENVIRONMENT ${TORTURE_ENVIRONMENT})
+ ENVIRONMENT ${TORTURE_CLIENT_ENVIRONMENT})
endif()
endforeach()