aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 00000000..3acee2ea
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,19 @@
+project(tests C)
+
+
+set(TORTURE_LIBRARY torture)
+
+include_directories(
+ ${LIBSSH_PUBLIC_INCLUDE_DIRS}
+ ${CHECK_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+# create test library
+add_library(${TORTURE_LIBRARY} SHARED torture.c cmdline.c)
+target_link_libraries(${TORTURE_LIBRARY} ${CHECK_LIBRARIES} ${LIBSSH_LIBRARY})
+
+set(TEST_TARGET_LIBRARIES ${SUPPORT_LIBRARY})
+
+add_subdirectory(unittests)