aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4edc59f4..8d4613ff 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -164,15 +164,9 @@ set(libssh_SRCS
external/ge25519.c
external/poly1305.c
external/sc25519.c
+ chachapoly.c
)
-if (NOT WITH_MBEDTLS)
- set(libssh_SRCS
- ${libssh_SRCS}
- chachapoly.c
- )
-endif (NOT WITH_MBEDTLS)
-
if (WITH_GCRYPT)
set(libssh_SRCS
${libssh_SRCS}