aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fc01df3a..d4949c3a 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -64,12 +64,12 @@ if (WITH_ZLIB)
)
endif (WITH_ZLIB)
-if (GSSAPI_LIBS)
+if (WITH_GSSAPI AND GSSAPI_LIBS)
set(LIBSSH_LINK_LIBRARIES
${LIBSSH_LINK_LIBRARIES}
${GSSAPI_LIBS}
)
-endif (GSSAPI_LIBS)
+endif (WITH_GSSAPI AND GSSAPI_LIBS)
set(LIBSSH_LINK_LIBRARIES
${LIBSSH_LINK_LIBRARIES}
@@ -102,7 +102,6 @@ set(libssh_SRCS
ecdh.c
error.c
getpass.c
- gssapi.c
init.c
kex.c
known_hosts.c
@@ -181,6 +180,13 @@ if (WITH_ZLIB)
)
endif(WITH_ZLIB)
+if (WITH_GSSAPI AND GSSAPI_LIBS)
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ gssapi.c
+ )
+endif (WITH_GSSAPI AND GSSAPI_LIBS)
+
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
${LIBSSH_PRIVATE_INCLUDE_DIRS}