aboutsummaryrefslogtreecommitdiff
path: root/include/libssh/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/libssh/CMakeLists.txt')
-rw-r--r--include/libssh/CMakeLists.txt20
1 files changed, 17 insertions, 3 deletions
diff --git a/include/libssh/CMakeLists.txt b/include/libssh/CMakeLists.txt
index bfbebdd8..dc67ab96 100644
--- a/include/libssh/CMakeLists.txt
+++ b/include/libssh/CMakeLists.txt
@@ -3,18 +3,32 @@ project(libssh-headers C)
set(libssh_HDRS
libssh.h
crypto.h
- server.h
sftp.h
ssh1.h
ssh2.h
)
-INSTALL(
+install(
FILES
${libssh_HDRS}
DESTINATION
${INCLUDE_INSTALL_DIR}/${APPLICATION_NAME}
COMPONENT
- libraries
+ headers
)
+if (WITH_SERVER)
+ set(server_HDRS
+ server.h
+ )
+
+ install(
+ FILES
+ ${server_HDRS}
+ DESTINATION
+ ${INCLUDE_INSTALL_DIR}/${APPLICATION_NAME}
+ COMPONENT
+ libraries
+ )
+endif (WITH_SERVER)
+