aboutsummaryrefslogtreecommitdiff
path: root/include/libssh/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/libssh/CMakeLists.txt')
-rw-r--r--include/libssh/CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/include/libssh/CMakeLists.txt b/include/libssh/CMakeLists.txt
index af7b2ebb..2b9fac6f 100644
--- a/include/libssh/CMakeLists.txt
+++ b/include/libssh/CMakeLists.txt
@@ -3,11 +3,23 @@ project(libssh-headers C)
set(libssh_HDRS
libssh.h
crypto.h
- sftp.h
- ssh1.h
ssh2.h
)
+if (WITH_SFTP)
+ set(libssh_HDRS
+ ${libssh_HDRS}
+ sftp.h
+ )
+endif (WITH_SFTP)
+
+if (WITH_SSH1)
+ set(libssh_HDRS
+ ${libssh_HDRS}
+ ssh1.h
+ )
+endif (WITH_SSH1)
+
if (WITH_SERVER)
set(libssh_HDRS
${libssh_HDRS}