aboutsummaryrefslogtreecommitdiff
path: root/include/libssh/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/libssh/CMakeLists.txt')
-rw-r--r--include/libssh/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/libssh/CMakeLists.txt b/include/libssh/CMakeLists.txt
index acc966e3..83e7b9f8 100644
--- a/include/libssh/CMakeLists.txt
+++ b/include/libssh/CMakeLists.txt
@@ -31,3 +31,9 @@ install(
headers
)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libssh_version.h.cmake
+ ${libssh_BINARY_DIR}/include/libssh/libssh_version.h
+ @ONLY)
+install(FILES ${libssh_BINARY_DIR}/include/libssh/libssh_version.h
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${APPLICATION_NAME}
+ COMPONENT headers)