aboutsummaryrefslogtreecommitdiff
path: root/include/libssh/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/libssh/CMakeLists.txt')
-rw-r--r--include/libssh/CMakeLists.txt22
1 files changed, 7 insertions, 15 deletions
diff --git a/include/libssh/CMakeLists.txt b/include/libssh/CMakeLists.txt
index dc67ab96..af7b2ebb 100644
--- a/include/libssh/CMakeLists.txt
+++ b/include/libssh/CMakeLists.txt
@@ -8,6 +8,13 @@ set(libssh_HDRS
ssh2.h
)
+if (WITH_SERVER)
+ set(libssh_HDRS
+ ${libssh_HDRS}
+ server.h
+ )
+endif (WITH_SERVER)
+
install(
FILES
${libssh_HDRS}
@@ -17,18 +24,3 @@ install(
headers
)
-if (WITH_SERVER)
- set(server_HDRS
- server.h
- )
-
- install(
- FILES
- ${server_HDRS}
- DESTINATION
- ${INCLUDE_INSTALL_DIR}/${APPLICATION_NAME}
- COMPONENT
- libraries
- )
-endif (WITH_SERVER)
-