aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 00000000..3f6dd063
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,15 @@
+project(libssh-library C)
+
+set(examples_SRCS
+ libssh_scp.c
+ authentication.c
+ knownhosts.c
+)
+
+include_directories(
+ ${LIBSSH_PUBLIC_INCLUDE_DIRS}
+)
+
+add_executable(libssh_scp ${examples_SRCS})
+
+target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY} )