aboutsummaryrefslogtreecommitdiff
path: root/tests/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2018-09-07 15:26:49 +0200
committerAndreas Schneider <asn@cryptomilk.org>2018-10-16 09:19:03 +0200
commite1548a71bdac73da084174ab1d6d2713edd93f6e (patch)
tree82dacf3432145a8d6f5cfe1f359721deb43d1d97 /tests/unittests/CMakeLists.txt
parent75be012b4a14f4550ce6ad3f126e559f44dbde76 (diff)
downloadlibssh-e1548a71bdac73da084174ab1d6d2713edd93f6e.tar.gz
libssh-e1548a71bdac73da084174ab1d6d2713edd93f6e.tar.xz
libssh-e1548a71bdac73da084174ab1d6d2713edd93f6e.zip
CVE-2018-10933: Add tests for packet filtering
Created the test torture_packet_filter.c which tests if packets are being correctly filtered. Fixes T101 Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/unittests/CMakeLists.txt')
-rw-r--r--tests/unittests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unittests/CMakeLists.txt b/tests/unittests/CMakeLists.txt
index 97234fd0..5c3b723f 100644
--- a/tests/unittests/CMakeLists.txt
+++ b/tests/unittests/CMakeLists.txt
@@ -15,6 +15,7 @@ set(LIBSSH_UNIT_TESTS
torture_isipaddr
torture_knownhosts_parsing
torture_hashes
+ torture_packet_filter
)
set(LIBSSH_THREAD_UNIT_TESTS