aboutsummaryrefslogtreecommitdiff
path: root/tests/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2018-11-19 13:10:48 +0100
committerAndreas Schneider <asn@cryptomilk.org>2018-11-28 15:51:06 +0100
commit78b1f0ead38f8086ebc5210823f470bfcaff742f (patch)
tree9b788900083bd40fd846df19428d3d8dcc667993 /tests/unittests/CMakeLists.txt
parent31527d41059cf6e7461e0cd1347c9ff1f5d03287 (diff)
downloadlibssh-78b1f0ead38f8086ebc5210823f470bfcaff742f.tar.gz
libssh-78b1f0ead38f8086ebc5210823f470bfcaff742f.tar.xz
libssh-78b1f0ead38f8086ebc5210823f470bfcaff742f.zip
tests: Introduce torture_create_temp_file()
Introduced torture_create_temp_file() and torture_close_fp() to allow creating temprary files transparently in Unix and Windows environment. This also adds a unit test for the added functions. Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/unittests/CMakeLists.txt')
-rw-r--r--tests/unittests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unittests/CMakeLists.txt b/tests/unittests/CMakeLists.txt
index 04e905ca..730da341 100644
--- a/tests/unittests/CMakeLists.txt
+++ b/tests/unittests/CMakeLists.txt
@@ -17,6 +17,7 @@ set(LIBSSH_UNIT_TESTS
torture_hashes
torture_packet_filter
torture_temp_dir
+ torture_temp_file
)
set(LIBSSH_THREAD_UNIT_TESTS