aboutsummaryrefslogtreecommitdiff
path: root/tests/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2018-10-24 20:01:04 +0200
committerAndreas Schneider <asn@cryptomilk.org>2018-11-28 15:51:06 +0100
commit65e16b8d9e508284ce5bda981a6d01adedbc37f0 (patch)
tree29b428705692713b3f4299074c94955f64697863 /tests/unittests/CMakeLists.txt
parent1f6b92973547234a00fbdd445840b181c631d91d (diff)
downloadlibssh-65e16b8d9e508284ce5bda981a6d01adedbc37f0.tar.gz
libssh-65e16b8d9e508284ce5bda981a6d01adedbc37f0.tar.xz
libssh-65e16b8d9e508284ce5bda981a6d01adedbc37f0.zip
tests: Introduce torture_make_temp_dir()
Introduces a function to create temporary dir for testing purposes. Also adds a minimal test for the temporary directory creation. Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/unittests/CMakeLists.txt')
-rw-r--r--tests/unittests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unittests/CMakeLists.txt b/tests/unittests/CMakeLists.txt
index 5c3b723f..04e905ca 100644
--- a/tests/unittests/CMakeLists.txt
+++ b/tests/unittests/CMakeLists.txt
@@ -16,6 +16,7 @@ set(LIBSSH_UNIT_TESTS
torture_knownhosts_parsing
torture_hashes
torture_packet_filter
+ torture_temp_dir
)
set(LIBSSH_THREAD_UNIT_TESTS