aboutsummaryrefslogtreecommitdiff
path: root/tests/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2018-01-08 21:49:49 +0100
committerAndreas Schneider <asn@cryptomilk.org>2018-01-10 22:27:52 +0100
commit59308bc269c92cded590bdda1d9dc997a409275f (patch)
treefe6491974805d29975904c81728caa083390a6e5 /tests/unittests/CMakeLists.txt
parentfd2ef07f372819e4eccbd85b7a0388c9c41eb31d (diff)
downloadlibssh-59308bc269c92cded590bdda1d9dc997a409275f.tar.gz
libssh-59308bc269c92cded590bdda1d9dc997a409275f.tar.xz
libssh-59308bc269c92cded590bdda1d9dc997a409275f.zip
tests: Move dsa tests to own test file
Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/unittests/CMakeLists.txt')
-rw-r--r--tests/unittests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/unittests/CMakeLists.txt b/tests/unittests/CMakeLists.txt
index e1351574..e9639474 100644
--- a/tests/unittests/CMakeLists.txt
+++ b/tests/unittests/CMakeLists.txt
@@ -16,6 +16,10 @@ if (UNIX AND NOT WIN32)
# requires ssh-keygen
add_cmocka_test(torture_keyfiles torture_keyfiles.c ${TORTURE_LIBRARY})
add_cmocka_test(torture_pki torture_pki.c ${TORTURE_LIBRARY})
+
+ if (HAVE_DSA)
+ add_cmocka_test(torture_pki_dsa torture_pki_dsa.c ${TORTURE_LIBRARY})
+ endif()
# requires /dev/null
add_cmocka_test(torture_channel torture_channel.c ${TORTURE_LIBRARY})
# requires pthread