aboutsummaryrefslogtreecommitdiff
path: root/tests/unittests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2019-05-15 17:48:41 +0200
committerAndreas Schneider <asn@cryptomilk.org>2019-06-12 10:17:54 +0200
commit2c4850cbbda69330958fd0fa66c52dac006d3bc7 (patch)
tree0484295510ceeed244bec5b74da7d26952fdfeb4 /tests/unittests/CMakeLists.txt
parentb0ff64bf1b177f3272cb0d4858e59f66629fa739 (diff)
downloadlibssh-2c4850cbbda69330958fd0fa66c52dac006d3bc7.tar.gz
libssh-2c4850cbbda69330958fd0fa66c52dac006d3bc7.tar.xz
libssh-2c4850cbbda69330958fd0fa66c52dac006d3bc7.zip
token, kex: Add functions to handle tokens lists
The added functions allow splitting chains of tokens separated by a given character (usually ','), and extracting matching parts between two chains of tokens. The previously existing functions in kex.c were replaced by the introduced ones. Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Jakub Jelen <jjelen@redhat.com>
Diffstat (limited to 'tests/unittests/CMakeLists.txt')
-rw-r--r--tests/unittests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/unittests/CMakeLists.txt b/tests/unittests/CMakeLists.txt
index 389100bd..6f49e0dc 100644
--- a/tests/unittests/CMakeLists.txt
+++ b/tests/unittests/CMakeLists.txt
@@ -20,6 +20,7 @@ set(LIBSSH_UNIT_TESTS
torture_temp_file
torture_push_pop_dir
torture_session_keys
+ torture_tokens
)
set(LIBSSH_THREAD_UNIT_TESTS