aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Jelen <jjelen@redhat.com>2018-10-02 15:42:33 +0200
committerAndreas Schneider <asn@cryptomilk.org>2018-10-05 12:09:45 +0200
commitc0d9aeda184d5b437ad1f033e2a6206a166057e2 (patch)
tree875471c773cef63830910d9d35e38c358328b064 /tests/client/CMakeLists.txt
parent82b2d31c29e34d855ef86f41cc51447ab48401df (diff)
downloadlibssh-c0d9aeda184d5b437ad1f033e2a6206a166057e2.tar.gz
libssh-c0d9aeda184d5b437ad1f033e2a6206a166057e2.tar.xz
libssh-c0d9aeda184d5b437ad1f033e2a6206a166057e2.zip
Assorted changes to make knownhosts test work
Cherry-picked from the following commit: b65dcb3a358aa432c8f455de9a04d3c8d6cd9766
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rw-r--r--tests/client/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index dc1c4b3b..d1f895bc 100644
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -2,7 +2,6 @@ project(clienttests C)
add_cmocka_test(torture_auth torture_auth.c ${TORTURE_LIBRARY})
add_cmocka_test(torture_connect torture_connect.c ${TORTURE_LIBRARY})
-add_cmocka_test(torture_knownhosts torture_knownhosts.c ${TORTURE_LIBRARY})
add_cmocka_test(torture_proxycommand torture_proxycommand.c ${TORTURE_LIBRARY})
add_cmocka_test(torture_session torture_session.c ${TORTURE_LIBRARY})
add_cmocka_test(torture_forward torture_forward.c ${TORTURE_LIBRARY})
@@ -14,7 +13,8 @@ if (WITH_SFTP)
endif (WITH_SFTP)
set(LIBSSH_CLIENT_TESTS
- torture_algorithms)
+ torture_algorithms
+ torture_knownhosts)
foreach(_CLI_TEST ${LIBSSH_CLIENT_TESTS})
add_cmocka_test(${_CLI_TEST} ${_CLI_TEST}.c ${TORTURE_LIBRARY})