aboutsummaryrefslogtreecommitdiff
path: root/tests/client/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Jelen <jjelen@redhat.com>2018-10-02 19:13:09 +0200
committerAndreas Schneider <asn@cryptomilk.org>2018-10-05 12:09:45 +0200
commit0f9e6598efc3c54f621585e78e394221be326b19 (patch)
tree55ae0dedfa33a206404753c49a20fffc837cc891 /tests/client/CMakeLists.txt
parentf8007d71477df426374cded3852fd894adc5650d (diff)
downloadlibssh-0f9e6598efc3c54f621585e78e394221be326b19.tar.gz
libssh-0f9e6598efc3c54f621585e78e394221be326b19.tar.xz
libssh-0f9e6598efc3c54f621585e78e394221be326b19.zip
Assorted changes to make the sftp_dir test working
Cherry-picked from the following commit: af3de262b69f44ba84009b9aba644b5f1cf3b1a7
Diffstat (limited to 'tests/client/CMakeLists.txt')
-rw-r--r--tests/client/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/client/CMakeLists.txt b/tests/client/CMakeLists.txt
index 52f92602..edc4ec75 100644
--- a/tests/client/CMakeLists.txt
+++ b/tests/client/CMakeLists.txt
@@ -6,7 +6,6 @@ add_cmocka_test(torture_proxycommand torture_proxycommand.c ${TORTURE_LIBRARY})
add_cmocka_test(torture_session torture_session.c ${TORTURE_LIBRARY})
if (WITH_SFTP)
add_cmocka_test(torture_sftp_static torture_sftp_static.c ${TORTURE_LIBRARY})
- add_cmocka_test(torture_sftp_dir torture_sftp_dir.c ${TORTURE_LIBRARY})
add_cmocka_test(torture_sftp_read torture_sftp_read.c ${TORTURE_LIBRARY})
endif (WITH_SFTP)
@@ -16,6 +15,12 @@ set(LIBSSH_CLIENT_TESTS
torture_request_env
torture_forward)
+if (WITH_SFTP)
+ set(LIBSSH_CLIENT_TESTS
+ ${LIBSSH_CLIENT_TESTS}
+ torture_sftp_dir)
+endif (WITH_SFTP)
+
foreach(_CLI_TEST ${LIBSSH_CLIENT_TESTS})
add_cmocka_test(${_CLI_TEST} ${_CLI_TEST}.c ${TORTURE_LIBRARY})