aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2011-08-09 19:52:26 +0200
committerAndreas Schneider <asn@cryptomilk.org>2011-08-13 11:07:57 +0200
commitf421c0591352a1e2f535ba3a2c7b6baf5c3282a0 (patch)
tree111ea642e3ccc06964f35fcba53ee0b6711217d4 /tests/CMakeLists.txt
parente92787395a2780ff71e1eb313fc37646f6361def (diff)
downloadlibssh-f421c0591352a1e2f535ba3a2c7b6baf5c3282a0.tar.gz
libssh-f421c0591352a1e2f535ba3a2c7b6baf5c3282a0.tar.xz
libssh-f421c0591352a1e2f535ba3a2c7b6baf5c3282a0.zip
cmake: Check for argp library only on bsd and solaris.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index e6205616..802ee567 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,6 +1,8 @@
project(tests C)
-find_package(Argp)
+if (BSD OR SOLARIS)
+ find_package(Argp)
+endif (BSD OR SOLARIS)
set(TORTURE_LIBRARY torture)