aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-12-29 20:11:00 +0100
committerAndreas Schneider <asn@cynapses.org>2010-12-29 20:11:00 +0100
commitad231ccd30c5e83deefb412e7d9d78dcd98b2b7b (patch)
treee9f3e5d7bc64b43bb617c1e98785354fc1969703 /tests/CMakeLists.txt
parentd4a6c27a83b37a10aea5b36588f07fff562a896d (diff)
downloadlibssh-ad231ccd30c5e83deefb412e7d9d78dcd98b2b7b.tar.gz
libssh-ad231ccd30c5e83deefb412e7d9d78dcd98b2b7b.tar.xz
libssh-ad231ccd30c5e83deefb412e7d9d78dcd98b2b7b.zip
cmake: Fixed test includes and libraries.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 11fb9032..19823608 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -4,14 +4,14 @@ set(TORTURE_LIBRARY torture)
include_directories(
${LIBSSH_PUBLIC_INCLUDE_DIRS}
+ ${LIBSSH_PRIVATE_INCLUDE_DIRS}
${CMOCKERY_INCLUDE_DIRS}
- ${CMAKE_BINARY_DIR}
${CMAKE_SOURCE_DIR}/src
${CMAKE_CURRENT_SOURCE_DIR}
)
# create test library
-add_library(${TORTURE_LIBRARY} SHARED torture.c)
+add_library(${TORTURE_LIBRARY} STATIC torture.c)
target_link_libraries(${TORTURE_LIBRARY}
${CMOCKERY_LIBRARY}
${LIBSSH_STATIC_LIBRARY}
@@ -20,7 +20,7 @@ target_link_libraries(${TORTURE_LIBRARY}
${LIBSSH_THREADS_LINK_LIBRARIES}
)
-set(TEST_TARGET_LIBRARIES ${SUPPORT_LIBRARY} ${LIBSSH_LINK_LIBRARIES})
+set(TEST_TARGET_LIBRARIES ${TORTURE_LIBRARY} ${LIBSSH_LINK_LIBRARIES})
add_subdirectory(unittests)
if (WITH_CLIENT_TESTING)
@@ -29,5 +29,5 @@ endif (WITH_CLIENT_TESTING)
if (WITH_BENCHMARKS)
add_subdirectory(benchmarks)
-endif (WITH_BENCHMARKS)
+endif (WITH_BENCHMARKS)