aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Jelen <jjelen@redhat.com>2019-06-20 17:45:49 +0200
committerJakub Jelen <jjelen@redhat.com>2019-06-20 17:45:52 +0200
commita4fa51454910f5d435e79248d5d0fd39703c4e28 (patch)
treeb6ee28e5a719b09d4170fadb41413b7aa11dd386 /tests/CMakeLists.txt
parentd5095a55b99198d7fa2fc4b8f1a1ca587b50ce9a (diff)
downloadlibssh-a4fa51454910f5d435e79248d5d0fd39703c4e28.tar.gz
libssh-a4fa51454910f5d435e79248d5d0fd39703c4e28.tar.xz
libssh-a4fa51454910f5d435e79248d5d0fd39703c4e28.zip
tests: Filter out bogus output from openssh in FIPS Mode
The OpenSSH in RHEL 8 in FIPS Mode outputs information about this on start and it needs to be skipped for the version detection (and build) to pass: $ ssh -V FIPS mode initialized OpenSSH_8.0p1, OpenSSL 1.1.1c FIPS 28 May 2019 Signed-off-by: Jakub Jelen <jjelen@redhat.com> Reviewed-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 8b235940..aeb0b17c 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -67,8 +67,8 @@ if (CLIENT_TESTING)
find_program(SSH_EXECUTABLE NAMES ssh)
if (SSH_EXECUTABLE)
execute_process(COMMAND ${SSH_EXECUTABLE} -V ERROR_VARIABLE OPENSSH_VERSION_STR)
- string(REGEX REPLACE "^OpenSSH_([0-9]).[0-9].*$" "\\1" OPENSSH_VERSION_MAJOR "${OPENSSH_VERSION_STR}")
- string(REGEX REPLACE "^OpenSSH_[0-9].([0-9]).*$" "\\1" OPENSSH_VERSION_MINOR "${OPENSSH_VERSION_STR}")
+ string(REGEX REPLACE "^.*OpenSSH_([0-9]).[0-9].*$" "\\1" OPENSSH_VERSION_MAJOR "${OPENSSH_VERSION_STR}")
+ string(REGEX REPLACE "^.*OpenSSH_[0-9].([0-9]).*$" "\\1" OPENSSH_VERSION_MINOR "${OPENSSH_VERSION_STR}")
add_definitions(-DOPENSSH_VERSION_MAJOR=${OPENSSH_VERSION_MAJOR} -DOPENSSH_VERSION_MINOR=${OPENSSH_VERSION_MINOR})
endif()