aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2014-04-15 21:12:56 +0200
committerAndreas Schneider <asn@cryptomilk.org>2016-01-14 08:04:49 +0100
commit6596d27e1903849d077b31b8b1ba89bad9758707 (patch)
tree9db26ac600a83d70e5195a9f64d4add9877ac42d /tests/CMakeLists.txt
parented6294b4bb94f49e03426dc73e60c1792bf16553 (diff)
downloadlibssh-6596d27e1903849d077b31b8b1ba89bad9758707.tar.gz
libssh-6596d27e1903849d077b31b8b1ba89bad9758707.tar.xz
libssh-6596d27e1903849d077b31b8b1ba89bad9758707.zip
cmake: Search for cwrap and sshd.
Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d87c9c2f..94939560 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -44,6 +44,18 @@ set(TEST_TARGET_LIBRARIES
add_subdirectory(unittests)
if (WITH_CLIENT_TESTING)
+ find_package(socket_wrapper 1.1.5 REQUIRED)
+ find_package(nss_wrapper 1.1.2 REQUIRED)
+ find_program(SSHD_EXECUTABLE
+ NAME
+ sshd
+ PATHS
+ /sbin
+ /usr/sbin
+ /usr/local/sbin)
+ if (NOT SSHD_EXECUTABLE)
+ message(SEND_ERROR "Could not find sshd which is required for client testing")
+ endif()
add_subdirectory(client)
endif (WITH_CLIENT_TESTING)