aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2010-03-02 13:47:14 +0100
committerAndreas Schneider <mail@cynapses.org>2010-03-02 13:54:14 +0100
commit464176d5111676161d809ac3f5aeaa0f9fb2ff5b (patch)
treef9ca2912faa6b68e23603438fc5f13ad19702789 /tests/CMakeLists.txt
parente8a1d135e21721426851312dc2a9180e5c38273f (diff)
downloadlibssh-464176d5111676161d809ac3f5aeaa0f9fb2ff5b.tar.gz
libssh-464176d5111676161d809ac3f5aeaa0f9fb2ff5b.tar.xz
libssh-464176d5111676161d809ac3f5aeaa0f9fb2ff5b.zip
Added unit testing support using check.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 00000000..3acee2ea
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,19 @@
+project(tests C)
+
+
+set(TORTURE_LIBRARY torture)
+
+include_directories(
+ ${LIBSSH_PUBLIC_INCLUDE_DIRS}
+ ${CHECK_INCLUDE_DIRS}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+# create test library
+add_library(${TORTURE_LIBRARY} SHARED torture.c cmdline.c)
+target_link_libraries(${TORTURE_LIBRARY} ${CHECK_LIBRARIES} ${LIBSSH_LIBRARY})
+
+set(TEST_TARGET_LIBRARIES ${SUPPORT_LIBRARY})
+
+add_subdirectory(unittests)