aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2014-02-02 20:56:21 +0100
committerAris Adamantiadis <aris@0xbadc0de.be>2014-02-02 20:56:21 +0100
commit3bdc2b1d4f1f0bb114b82f5e0b838e808b691d0a (patch)
tree55cabc41e3b677f8aaef64649402736556911241 /tests/CMakeLists.txt
parent1e37430dbeb6db8bafc5c5382861b99ac192fa75 (diff)
downloadlibssh-3bdc2b1d4f1f0bb114b82f5e0b838e808b691d0a.tar.gz
libssh-3bdc2b1d4f1f0bb114b82f5e0b838e808b691d0a.tar.xz
libssh-3bdc2b1d4f1f0bb114b82f5e0b838e808b691d0a.zip
build: fix cmake bug introduced yesterday
Compilation failed on OSX because of the missing OR OSX
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index bb67939d..e1a8166b 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,8 +1,8 @@
project(tests C)
-if (BSD OR SOLARIS)
+if (BSD OR SOLARIS OR OSX)
find_package(Argp)
-endif (BSD OR SOLARIS)
+endif (BSD OR SOLARIS OR OSX)
set(TORTURE_LIBRARY torture)
@@ -25,7 +25,7 @@ target_link_libraries(${TORTURE_LIBRARY}
${LIBSSH_LINK_LIBRARIES}
${LIBSSH_THREADS_STATIC_LIBRARY}
${LIBSSH_THREADS_LINK_LIBRARIES}
- ${ARGP_LIBRARY}
+ ${ARGP_LIBRARIES}
)
set(TEST_TARGET_LIBRARIES