aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2016-03-17 10:45:40 +0100
committerAndreas Schneider <asn@cryptomilk.org>2016-03-17 10:45:40 +0100
commit16d58e93afe2b780d140d53f50a48c049f6ce728 (patch)
treef39e312a3389e43934cce158e8b116873f9ac7b9 /tests/CMakeLists.txt
parent2384236849001fcbbe4b15df237cca0e512f61f7 (diff)
downloadlibssh-16d58e93afe2b780d140d53f50a48c049f6ce728.tar.gz
libssh-16d58e93afe2b780d140d53f50a48c049f6ce728.tar.xz
libssh-16d58e93afe2b780d140d53f50a48c049f6ce728.zip
cmake: Fix torture build
Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 30a03a58..f538a045 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -31,9 +31,11 @@ endif (LIBSSH_THREADS)
# create test library
add_library(${TORTURE_LIBRARY} STATIC cmdline.c torture.c)
-if (ARGP_LIBRARY)
target_link_libraries(${TORTURE_LIBRARY}
${TORTURE_LINK_LIBRARIES}
+ )
+if (ARGP_LIBRARY)
+ target_link_libraries(${TORTURE_LIBRARY}
${ARGP_LIBRARY}
)
endif()