aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2019-10-20 00:52:47 +0200
committerAndreas Schneider <asn@cryptomilk.org>2019-12-23 14:31:32 +0100
commit1089948346640061e3a723737cfdd8515d4986d5 (patch)
tree317c8c95f24cc91428475b2a868d32b071cbf2c0 /tests/CMakeLists.txt
parent7ec67011c5bb9cf700a76084550b095640605c85 (diff)
downloadlibssh-1089948346640061e3a723737cfdd8515d4986d5.tar.gz
libssh-1089948346640061e3a723737cfdd8515d4986d5.tar.xz
libssh-1089948346640061e3a723737cfdd8515d4986d5.zip
tests: use detected sshd path
The static sshd directory wasn't matching the detected sshd and prevented the testcases to be run against local OpenSSH builts Signed-off-by: Aris Adamantiadis <aris@0xbadc0de.be> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 20e42f1a..68b045bd 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -104,23 +104,23 @@ if (SSH_EXECUTABLE)
endif()
+find_program(SSHD_EXECUTABLE
+ NAME
+ sshd
+ PATHS
+ /sbin
+ /usr/sbin
+ /usr/local/sbin)
+
if (CLIENT_TESTING OR SERVER_TESTING)
find_package(socket_wrapper 1.1.5 REQUIRED)
find_package(nss_wrapper 1.1.2 REQUIRED)
find_package(uid_wrapper 1.2.0 REQUIRED)
find_package(pam_wrapper 1.0.1 REQUIRED)
- find_program(SSHD_EXECUTABLE
- NAME
- sshd
- PATHS
- /sbin
- /usr/sbin
- /usr/local/sbin)
if (NOT SSHD_EXECUTABLE)
message(SEND_ERROR "Could not find sshd which is required for client testing")
endif()
-
find_program(NC_EXECUTABLE
NAME
nc