aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Jelen <jjelen@redhat.com>2019-02-02 16:49:05 +0100
committerAndreas Schneider <asn@cryptomilk.org>2019-02-07 10:30:05 +0100
commitfffa66698f6cdc2046dc54b5f40ecc5446cdcbca (patch)
tree2203b3505a7ead2c59275be24c967d697bd05886 /src/CMakeLists.txt
parenta17058014726a21fd714ccb9152ec2d86458b5a1 (diff)
downloadlibssh-fffa66698f6cdc2046dc54b5f40ecc5446cdcbca.tar.gz
libssh-fffa66698f6cdc2046dc54b5f40ecc5446cdcbca.tar.xz
libssh-fffa66698f6cdc2046dc54b5f40ecc5446cdcbca.zip
Allow building without Group Exchange support
Signed-off-by: Jakub Jelen <jjelen@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ff3b3a47..3261d42c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -126,7 +126,6 @@ set(libssh_SRCS
connector.c
curve25519.c
dh.c
- dh-gex.c
ecdh.c
error.c
getpass.c
@@ -243,6 +242,13 @@ if (WITH_SERVER)
)
endif (WITH_SERVER)
+if (WITH_GEX)
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ dh-gex.c
+ )
+endif (WITH_GEX)
+
if (WITH_ZLIB)
set(libssh_SRCS
${libssh_SRCS}