aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2019-02-22 13:06:49 +0100
committerAndreas Schneider <asn@cryptomilk.org>2019-04-01 08:25:22 +0200
commit79049981a513f9a10fac0f153e9b0b588326021f (patch)
treeef01c66bf9bffe42b40e98ac4614cc5d5a7ddcb2 /src/CMakeLists.txt
parent19e886d6b1ed59bed6b8f6ba2eb5dd9e70395809 (diff)
downloadlibssh-79049981a513f9a10fac0f153e9b0b588326021f.tar.gz
libssh-79049981a513f9a10fac0f153e9b0b588326021f.tar.xz
libssh-79049981a513f9a10fac0f153e9b0b588326021f.zip
config: Move common parser functions to config_parser.c
This will allow the moved functions to be used in the server side configuration parser implementation. Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index fdb53baf..de66f056 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -163,6 +163,7 @@ set(libssh_SRCS
external/poly1305.c
external/sc25519.c
chachapoly.c
+ config_parser.c
)
if (DEFAULT_C_NO_DEPRECATION_FLAGS)