aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2011-08-07 13:08:49 +0200
committerAndreas Schneider <asn@cryptomilk.org>2011-08-08 15:28:31 +0200
commit6ccb3f7a8245c0c5e6b42cdeaae9d3285f9037bc (patch)
tree802b8833c0bef79b166fb363f45277087ed64a57 /src/CMakeLists.txt
parent37b80e92613de0e56b1558d09298899276b56217 (diff)
downloadlibssh-6ccb3f7a8245c0c5e6b42cdeaae9d3285f9037bc.tar.gz
libssh-6ccb3f7a8245c0c5e6b42cdeaae9d3285f9037bc.tar.xz
libssh-6ccb3f7a8245c0c5e6b42cdeaae9d3285f9037bc.zip
pki: Add pki_crypto.c.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt15
1 files changed, 10 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ef745620..392944a1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -114,11 +114,16 @@ set(libssh_SRCS
)
if (WITH_GCRYPT)
- set(libssh_SRCS
- ${libssh_SRCS}
- libgcrypt.c
- gcrypt_missing.c
- )
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ libgcrypt.c
+ gcrypt_missing.c
+ )
+else (WITH_GCRYPT)
+ set(libssh_SRCS
+ ${libssh_SRCS}
+ pki_crypto.c
+ )
endif (WITH_GCRYPT)
if (WITH_SFTP)