aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Wedderwille <davidwe@posteo.de>2020-05-07 15:07:04 +0200
committerAndreas Schneider <asn@cryptomilk.org>2020-05-15 18:39:21 +0200
commit641a80be74638be5b5114d148b5b3eb3e5c9293b (patch)
tree39c10bb0d99de2315a4bb3e2307b61a70f614008 /src/CMakeLists.txt
parentbee8ed82abbc1ee8c631691a131c3d6ec6ba0836 (diff)
downloadlibssh-641a80be74638be5b5114d148b5b3eb3e5c9293b.tar.gz
libssh-641a80be74638be5b5114d148b5b3eb3e5c9293b.tar.xz
libssh-641a80be74638be5b5114d148b5b3eb3e5c9293b.zip
cmake: add _POSIX_SOURCE
Fixes T228 Signed-off-by: David Wedderwille <davidwe@posteo.de> Reviewed-by: Andreas Schneider <asn@cryptomilk.org> Reviewed-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c6246625..621f8b35 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -379,6 +379,7 @@ endif (WITH_VISIBILITY_HIDDEN)
if (MINGW)
set_target_properties(ssh PROPERTIES LINK_FLAGS "-Wl,--enable-stdcall-fixup")
+ set_target_properties(ssh PROPERTIES COMPILE_FLAGS "-D_POSIX_SOURCE")
endif ()