aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2019-03-17 15:46:41 -0400
committerAndreas Schneider <asn@cryptomilk.org>2019-04-04 08:00:28 +0200
commit33399e52f0af482444b4e5168f3e94f01e86d303 (patch)
treea69cfb17061af8b12dec2a794367eca36a39a1ec /src/CMakeLists.txt
parent7551857d0862a3c170fd84459b3bb1ef0e06b31e (diff)
downloadlibssh-33399e52f0af482444b4e5168f3e94f01e86d303.tar.gz
libssh-33399e52f0af482444b4e5168f3e94f01e86d303.tar.xz
libssh-33399e52f0af482444b4e5168f3e94f01e86d303.zip
dh: Add OpenSSL libcrypto specific DH implementation
Signed-off-by: Simo Sorce <simo@redhat.com> Reviewed-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f37ac91e..db7e74a0 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -218,7 +218,7 @@ else (WITH_GCRYPT)
pki_crypto.c
ecdh_crypto.c
libcrypto.c
- dh_key.c
+ dh_crypto.c
)
if(OPENSSL_VERSION VERSION_LESS "1.1.0")
set(libssh_SRCS ${libssh_SRCS} libcrypto-compat.c)