aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan Dunn <amdunn@gmail.com>2014-04-12 16:11:13 -0500
committerAndreas Schneider <asn@cryptomilk.org>2014-04-22 09:24:54 +0200
commit099e2e8438621b2fefb12bd005f273200e03eb34 (patch)
treeb0b6cdb71d9416d2b26fa57393ff27d5b6af67b1 /src/CMakeLists.txt
parent291312c5e4774307a79365623065764220a673e9 (diff)
downloadlibssh-099e2e8438621b2fefb12bd005f273200e03eb34.tar.gz
libssh-099e2e8438621b2fefb12bd005f273200e03eb34.tar.xz
libssh-099e2e8438621b2fefb12bd005f273200e03eb34.zip
build: Do not link against libssl, only libcrypto
Signed-off-by: Alan Dunn <amdunn@gmail.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1891a00a..ae8eb6dc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -28,7 +28,7 @@ if (HAVE_LIBSOCKET)
)
endif (HAVE_LIBSOCKET)
-if (OPENSSL_LIBRARIES)
+if (OPENSSL_CRYPTO_LIBRARIES)
set(LIBSSH_PRIVATE_INCLUDE_DIRS
${LIBSSH_PRIVATE_INCLUDE_DIRS}
${OPENSSL_INCLUDE_DIRS}
@@ -36,9 +36,9 @@ if (OPENSSL_LIBRARIES)
set(LIBSSH_LINK_LIBRARIES
${LIBSSH_LINK_LIBRARIES}
- ${OPENSSL_LIBRARIES}
+ ${OPENSSL_CRYPTO_LIBRARIES}
)
-endif (OPENSSL_LIBRARIES)
+endif (OPENSSL_CRYPTO_LIBRARIES)
if (GCRYPT_LIBRARY)
set(LIBSSH_PRIVATE_INCLUDE_DIRS