aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorHeiko Thiery <heiko.thiery@gmail.com>2020-04-15 09:14:23 +0200
committerAndreas Schneider <asn@cryptomilk.org>2020-05-06 13:02:32 +0200
commitbee8ed82abbc1ee8c631691a131c3d6ec6ba0836 (patch)
treed7a89a4d6b3c060117411c69653a6b34f5ae2c2b /examples/CMakeLists.txt
parent4149cebd64a916e934a1485b75f464e26c9bf4ea (diff)
downloadlibssh-bee8ed82abbc1ee8c631691a131c3d6ec6ba0836.tar.gz
libssh-bee8ed82abbc1ee8c631691a131c3d6ec6ba0836.tar.xz
libssh-bee8ed82abbc1ee8c631691a131c3d6ec6ba0836.zip
cmake: Add autogenerated libssh_version.h
Set the cmake project verision to the autogenerated file to have a single point to set the version. This will be included in the libssh.h file. Pair-Programmed-With: Andreas Schneider <asn@cryptomilk.org> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com> Signed-off-by: Andreas Schneider <asn@cryptomilk.org> Reviewed-by: Jakub Jelen <jjelen@redhat.com>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index b3b6b358..4e09083a 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -6,7 +6,7 @@ set(examples_SRCS
connect_ssh.c
)
-include_directories(${libssh_BINARY_DIR})
+include_directories(${libssh_BINARY_DIR}/include ${libssh_BINARY_DIR})
if (ARGP_INCLUDE_DIR)
include_directories(${ARGP_INCLUDE_DIR})