aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2019-08-20 14:49:27 +0200
committerAndreas Schneider <asn@cryptomilk.org>2019-11-07 10:53:49 +0100
commitb30875c6c74391c5239b394ccdce91b45c1b1d2c (patch)
tree442fe34e76a5386a65e51b610fa77ec8427d9eb8 /examples/CMakeLists.txt
parentd02c06268eae9c9c5253bd88410863a2e8c66587 (diff)
downloadlibssh-b30875c6c74391c5239b394ccdce91b45c1b1d2c.tar.gz
libssh-b30875c6c74391c5239b394ccdce91b45c1b1d2c.tar.xz
libssh-b30875c6c74391c5239b394ccdce91b45c1b1d2c.zip
examples: Added keygen2 example
The added example is an application which can generate keys of different types using libssh. Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Jakub Jelen <jjelen@redhat.com>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index d064fd5d..17a7d149 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -38,6 +38,10 @@ if (UNIX AND NOT WIN32)
target_compile_options(ssh-client PRIVATE ${DEFAULT_C_COMPILE_FLAGS})
target_link_libraries(ssh-client ${LIBSSH_SHARED_LIBRARY})
+ add_executable(keygen2 keygen2.c ${examples_SRCS})
+ target_compile_options(keygen2 PRIVATE ${DEFAULT_C_COMPILE_FLAGS})
+ target_link_libraries(keygen2 ${LIBSSH_SHARED_LIBRARY})
+
if (WITH_SERVER AND (ARGP_LIBRARY OR HAVE_ARGP_H))
if (HAVE_LIBUTIL)
add_executable(ssh_server_fork ssh_server_fork.c)