aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorJakub Jelen <jjelen@redhat.com>2019-02-04 22:40:37 +0100
committerAndreas Schneider <asn@cryptomilk.org>2019-02-07 10:30:05 +0100
commit5700477f3e69c261608a14b1b2ff6c17104147fd (patch)
tree7c474a22663d7982bff5d03678ad861eae05ce74 /examples/CMakeLists.txt
parentfffa66698f6cdc2046dc54b5f40ecc5446cdcbca (diff)
downloadlibssh-5700477f3e69c261608a14b1b2ff6c17104147fd.tar.gz
libssh-5700477f3e69c261608a14b1b2ff6c17104147fd.tar.xz
libssh-5700477f3e69c261608a14b1b2ff6c17104147fd.zip
examples: Add simple way to generate key files from libssh
Signed-off-by: Jakub Jelen <jjelen@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 01dbf2d4..85bd3879 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -70,6 +70,10 @@ add_executable(senddata senddata.c ${examples_SRCS})
target_compile_options(senddata PRIVATE ${DEFAULT_C_COMPILE_FLAGS})
target_link_libraries(senddata ${LIBSSH_SHARED_LIBRARY})
+add_executable(keygen keygen.c)
+target_compile_options(keygen PRIVATE ${DEFAULT_C_COMPILE_FLAGS})
+target_link_libraries(keygen ${LIBSSH_SHARED_LIBRARY})
+
add_executable(libsshpp libsshpp.cpp)
target_link_libraries(libsshpp ${LIBSSH_SHARED_LIBRARY})